aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Benc <dusxmt@gmx.com>2015-02-05 17:12:54 +0100
committerLudovic Courtès <ludo@gnu.org>2015-09-04 13:50:38 +0200
commit0cce99684ae09808c7236350a7283084d0181de1 (patch)
tree43c2a46b74b810d5db811cbe28532c78117f76ba
parent66feaa320ecbe3e4fcc2b2d83c261b3839641f77 (diff)
downloadguix-0cce99684ae09808c7236350a7283084d0181de1.tar
guix-0cce99684ae09808c7236350a7283084d0181de1.tar.gz
gnu: gcc: Also substitute the dynamic linker name for GNU/Hurd.
* gnu/packages/gcc.scm (gcc-4.7): Also substitute the dynamic linker name for GNU (ie. Hurd) systems. Signed-off-by: Manolis Ragkousis <manolis837@gmail.com> Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gcc.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index dcac16d752..d2652aef3f 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -206,7 +206,7 @@ where the OS part is overloaded to denote a specific ABI---into GCC
;; Fix the dynamic linker's file name.
(substitute* (find-files "gcc/config"
- "^linux(64|-elf|-eabi)?\\.h$")
+ "^(linux|gnu)(64|-elf|-eabi)?\\.h$")
(("#define GLIBC_DYNAMIC_LINKER([^ ]*).*$" _ suffix)
(format #f "#define GLIBC_DYNAMIC_LINKER~a \"~a\"~%"
suffix