aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-03-12 10:32:45 +0100
committerRutger Helling <rhelling@mykolab.com>2018-03-12 10:52:48 +0100
commitf6246195e57d6e50b202bba6777cd70c64b36ce2 (patch)
tree1ab85e82e96efb80e45a95e3382ad208e3b9d0da
parent162189361e87996e2156598c3fe264fb5e918824 (diff)
downloadguix-f6246195e57d6e50b202bba6777cd70c64b36ce2.tar
guix-f6246195e57d6e50b202bba6777cd70c64b36ce2.tar.gz
gnu: Add wine-staging-patchset-data.
* gnu/packages/wine.scm (wine-staging-patchset-data): New variable.
-rw-r--r--gnu/packages/wine.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index e71538f1b0..df16b99280 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -26,9 +26,12 @@
#:use-module (guix download)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system trivial)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
#:use-module (gnu packages audio)
+ #:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages compression)
#:use-module (gnu packages cups)
@@ -212,6 +215,50 @@ integrate Windows applications into your desktop.")
(synopsis "Implementation of the Windows API (WoW64 version)")
(supported-systems '("x86_64-linux" "aarch64-linux"))))
+(define-public wine-staging-patchset-data
+ (package
+ (name "wine-staging-patchset-data")
+ (version "3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/wine-staging/wine-staging/archive/v"
+ version ".zip"))
+ (file-name (string-append name "-" version ".zip"))
+ (sha256
+ (base32
+ "16l28vrhqn27kipqwms622jz1prfky8qkjb8pj747k3qjnm2k1g9"))))
+ (build-system trivial-build-system)
+ (native-inputs
+ `(("bash" ,bash)
+ ("coreutils" ,coreutils)
+ ("unzip" ,unzip)))
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let* ((out (assoc-ref %outputs "out"))
+ (wine-staging (string-append out "/share/wine-staging"))
+ (source (assoc-ref %build-inputs "source"))
+ (sh (string-append (assoc-ref %build-inputs "bash") "/bin/bash"))
+ (env (string-append (assoc-ref %build-inputs "coreutils") "/bin/env"))
+ (unzip (string-append (assoc-ref %build-inputs "unzip") "/bin/unzip")))
+ (copy-file source (string-append ,name "-" ,version ".zip"))
+ (invoke unzip (string-append ,name "-" ,version ".zip"))
+ (substitute* (string-append "wine-staging-" ,version
+ "/patches/patchinstall.sh") (("/bin/sh") sh))
+ (substitute* (string-append "wine-staging-" ,version
+ "/patches/gitapply.sh") (("/usr/bin/env") env))
+ (mkdir-p wine-staging)
+ (copy-recursively (string-append "wine-staging-" ,version)
+ wine-staging)))))
+ (home-page "https://github.com/wine-staging")
+ (synopsis "Patchset for Wine")
+ (description
+ "wine-staging-patchset-data contains the patchset to build Wine-Staging.")
+ (license license:lgpl2.1+)))
+
(define-public wine-staging
(package
(inherit wine)