aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2018-03-12 17:42:48 +0100
committerJelle Licht <jlicht@fsfe.org>2018-03-12 18:04:05 +0100
commitf06e391338346cae54d23071f49e572b4b6e5bb3 (patch)
tree51e93ae7319da18bf78ed7fc2909f039e8d3826f
parentc0edb5b5430a5278a3ebc9aeea9d3c8ae9a2e1f1 (diff)
downloadguix-f06e391338346cae54d23071f49e572b4b6e5bb3.tar
guix-f06e391338346cae54d23071f49e572b4b6e5bb3.tar.gz
gnu: node: Update to 9.8.0.
* gnu/packages/node.scm (node): Update to 9.8.0. [arguments]: Remove 'doc-only' workaround. Re-enable fixed tests.
-rw-r--r--gnu/packages/node.scm32
1 files changed, 4 insertions, 28 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 982d3f905c..ea98f28efd 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -41,14 +41,14 @@
(define-public node
(package
(name "node")
- (version "9.4.0")
+ (version "9.8.0")
(source (origin
(method url-fetch)
(uri (string-append "http://nodejs.org/dist/v" version
"/node-v" version ".tar.gz"))
(sha256
(base32
- "0rx947ibcfpa0lf93nayfrmjls7r7svqsq87z0xmjzf8fb9361r4"))))
+ "1mjr1rm5w26c0yb4zq6z5yv3zbvqk18lwbswhwn1sha8hapinjp8"))))
(build-system gnu-build-system)
(arguments
;; TODO: Purge the bundled copies from the source.
@@ -77,29 +77,13 @@
(("'/usr/bin/env'")
(string-append "'" (which "env") "'")))
-
- ;; test-make-doc needs doc-only target, which is inhibited below
- (for-each delete-file
- '("test/doctool/test-make-doc.js"))
;; FIXME: These tests depend on being able to install eslint.
;; See https://github.com/nodejs/node/issues/17098.
(for-each delete-file
- '("test/parallel/test-eslint-crypto-check.js"
- "test/parallel/test-eslint-alphabetize-errors.js"
+ '("test/parallel/test-eslint-alphabetize-errors.js"
"test/parallel/test-eslint-buffer-constructor.js"
"test/parallel/test-eslint-documented-errors.js"
- "test/parallel/test-eslint-inspector-check.js"
- "test/parallel/test-eslint-lowercase-name-for-primitive.js"
- "test/parallel/test-eslint-no-unescaped-regexp-dot.js"
- "test/parallel/test-eslint-no-let-in-for-declaration.js"
- "test/parallel/test-eslint-number-isnan.js"
- "test/parallel/test-eslint-prefer-assert-iferror.js"
- "test/parallel/test-eslint-prefer-assert-methods.js"
- "test/parallel/test-eslint-prefer-common-expectserror.js"
- "test/parallel/test-eslint-prefer-common-mustnotcall.js"
- "test/parallel/test-eslint-prefer-util-format-errors.js"
- "test/parallel/test-eslint-require-buffer.js"
- "test/parallel/test-eslint-required-modules.js"))
+ "test/parallel/test-eslint-inspector-check.js"))
;; FIXME: These tests fail in the build container, but they don't
;; seem to be indicative of real problems in practice.
@@ -135,14 +119,6 @@
(string-append (assoc-ref inputs "python")
"/bin/python")
"configure" flags)))))
- (add-before 'check 'skip-check-doc-only
- (lambda _
- (substitute* "Makefile"
- ;; requires js-yaml, which is not part of the distribution,
- ;; and falls back to using npm to download it
- (("\\$\\(MAKE\\) doc-only" all)
- (string-append "#" all)))
- #t))
(add-after 'patch-shebangs 'patch-npm-shebang
(lambda* (#:key outputs #:allow-other-keys)
(let* ((bindir (string-append (assoc-ref outputs "out")