aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-11 18:50:30 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-03-12 18:47:16 +0100
commita3a7eb2fe22ec7567d036d174ef65bea4011575c (patch)
treee5ff906eca468d2186b65be48601195b51699031
parent5400fdfd5d3c2201ee3ea8ec0d55690c221a91d8 (diff)
downloadguix-a3a7eb2fe22ec7567d036d174ef65bea4011575c.tar
guix-a3a7eb2fe22ec7567d036d174ef65bea4011575c.tar.gz
gnu: rofi: Update to 1.5.0.
* gnu/packages/xdisorg.scm (rofi): Update to 1.5.0. [native-inputs]: Add GLIB:BIN. [arguments]: Add phase to create missing test files.
-rw-r--r--gnu/packages/xdisorg.scm29
1 files changed, 26 insertions, 3 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index a3630b3cb9..173de8e5a2 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1101,7 +1101,7 @@ connectivity of the X server running on a particular @code{DISPLAY}.")
(define-public rofi
(package
(name "rofi")
- (version "1.4.2")
+ (version "1.5.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/DaveDavenport/rofi/"
@@ -1109,7 +1109,7 @@ connectivity of the X server running on a particular @code{DISPLAY}.")
version "/rofi-" version ".tar.xz"))
(sha256
(base32
- "1129cbg76g56c6ckzj5y5haf92jxhx3b71cr3qmhrb0n8g4gi38s"))))
+ "0li2hl55sxzdpbxxiwgxsvkhyy6bh8qd2j1r8xh8y6q8a318zsz9"))))
(build-system gnu-build-system)
(inputs
`(("pango" ,pango)
@@ -1126,6 +1126,7 @@ connectivity of the X server running on a particular @code{DISPLAY}.")
`(("bison" ,bison)
("check" ,check)
("flex" ,flex)
+ ("glib:bin" ,glib "bin")
("pkg-config" ,pkg-config)))
(arguments
`(#:parallel-tests? #f ; May fail in some circumstances.
@@ -1136,7 +1137,29 @@ connectivity of the X server running on a particular @code{DISPLAY}.")
(substitute* '("test/helper-expand.c")
(("~root") "/root")
(("~") "")
- (("g_get_home_dir \\(\\)") "\"/\"")))))))
+ (("g_get_home_dir \\(\\)") "\"/\""))
+ #t))
+ (add-before 'check 'add-missing-configuration-files
+ (lambda _
+ ;; These files are missing in the 1.5.0 release, causing a test
+ ;; failure: <https://github.com/DaveDavenport/rofi/issues/782>.
+ (with-directory-excursion "subprojects/libnkutils/tests"
+ (mkdir "gtk-3.0")
+ (call-with-output-file "gtk-3.0/settings.ini"
+ (lambda (port)
+ (format port "[Settings]
+gtk-double-click-time = 300
+gtk-cursor-theme-name = gnome
+")))
+ (mkdir "gtk-4.0")
+ (call-with-output-file "gtk-4.0/settings.ini"
+ (lambda (port)
+ (format port "[Settings]
+gtk-double-click-time = 300
+gtk-icon-theme-name = nothing-like-this-theme
+gtk-enable-primary-paste = true
+")))
+ #t))))))
(home-page "https://davedavenport.github.io/rofi/")
(synopsis "Application launcher")
(description "Rofi is a minimalist application launcher. It memorizes which