aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-03 22:02:27 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-13 18:01:47 +0000
commit906dcb20f2847d4f886e482642e2a5d361c5c59c (patch)
tree26983d6e9939e0fe0b5764219763a7b90bb2f149
parent8456765772cb48a428a15719e32ab49c9d4d7a53 (diff)
downloadguix-906dcb20f2847d4f886e482642e2a5d361c5c59c.tar
guix-906dcb20f2847d4f886e482642e2a5d361c5c59c.tar.gz
gnu: Add makefile2graph.
* gnu/packages/code.scm (makefile2graph): New variable.
-rw-r--r--gnu/packages/code.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 13a89c7bcc..979c7a72b8 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -37,6 +37,7 @@
#:use-module (gnu packages databases)
#:use-module (gnu packages emacs)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages pcre)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages perl)
@@ -497,3 +498,32 @@ importantly we give you proper follow-symbol and find-references support.")
(description "This package provides a wrapper around @command{make} to
produce colored output.")
(license license:gpl2+)))
+
+(define-public makefile2graph
+ (package
+ (name "makefile2graph")
+ (version "1.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/lindenb/" name
+ "/archive/v" version ".tar.gz"))
+ (sha256
+ (base32
+ "0h1vchkpmm9h6s87p5nf0ksjxcmsxpx8k62a508w428n570wcr4l"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:test-target "test"
+ #:make-flags (list "CC=gcc" (string-append "prefix=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs
+ `(("graphviz" ,graphviz)))
+ (home-page "https://github.com/lindenb/makefile2graph")
+ (synopsis "Creates a graph of dependencies from GNU Make")
+ (description
+ "@code{make2graph} creates a graph of dependencies from GNU Make. The
+output is a graphviz-dot file, a Gexf-XML file or a list of the deepest
+independent targets.")
+ (license license:expat)))