aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-03-01 18:51:17 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-03-13 15:58:43 +0300
commit8456765772cb48a428a15719e32ab49c9d4d7a53 (patch)
tree527f171b541c5fbe061d985eab72bc7cef22dd2e
parent0982e5c7f1616ecef8ce61128ddf417df609d79f (diff)
downloadguix-8456765772cb48a428a15719e32ab49c9d4d7a53.tar
guix-8456765772cb48a428a15719e32ab49c9d4d7a53.tar.gz
gnu: Add flameshot.
* gnu/packages/image.scm (flameshot): New public variable.
-rw-r--r--gnu/packages/image.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index e3e3a3ccc7..b576c508ec 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -58,6 +58,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
+ #:use-module (gnu packages qt)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
@@ -1250,3 +1251,45 @@ such as images. This metadata can include captions and keywords, often used by
popular photo management applications. The library provides routines for
parsing, viewing, modifying, and saving this metadata.")
(license license:lgpl2.0+)))
+
+(define-public flameshot
+ (package
+ (name "flameshot")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/lupoDharkael/flameshot/archive/"
+ "v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0kp451bqgssvg8n3sg60s3fifplm9l5kxiij0yxkl864p2mhw8im"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("qttools" ,qttools)))
+ (inputs
+ `(("qtbase" ,qtbase)))
+ (arguments
+ `(#:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "qmake"
+ "CONFIG+=packaging"
+ (string-append "BASEDIR=" (assoc-ref outputs "out"))
+ "PREFIX=/"))))))
+ (home-page "https://github.com/lupoDharkael/flameshot")
+ (synopsis "Powerful yet simple to use screenshot software")
+ (description "Flameshot is a screenshot program.
+Features:
+
+@itemize
+@item Customizable appearance.
+@item Easy to use.
+@item In-app screenshot edition.
+@item DBus interface.
+@item Upload to Imgur.
+@end itemize\n")
+ (license license:gpl3+)))