aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-03-12 10:41:51 +0100
committerRutger Helling <rhelling@mykolab.com>2018-03-12 10:52:48 +0100
commit3139f18524334c4ba373f5f031dbab7f44c94650 (patch)
treea21803efa648e3c1daa69eb9714ad37a486377d5
parentb53b9c8dd12820a28775b295895fb0d32b8e0ed4 (diff)
downloadguix-3139f18524334c4ba373f5f031dbab7f44c94650.tar
guix-3139f18524334c4ba373f5f031dbab7f44c94650.tar.gz
gnu: wine64-staging: Update to 3.3.
* gnu/packages/wine.scm (wine64-staging): Update to 3.3. [arguments]: Remove 'hardcode-libvulkan-path phase. Add 'patch-source-wine-staging phase.
-rw-r--r--gnu/packages/wine.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 836ed0666e..e23dcc55f1 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -334,13 +334,13 @@ integrated into the main branch.")
(string-append "libdir=" %output "/lib/wine64"))
#:phases
(modify-phases %standard-phases
- (add-before 'configure 'hardcore-libvulkan-path
+ (add-before 'configure 'patch-source-wine-staging
(lambda* (#:key outputs #:allow-other-keys)
- (let* ((libvulkan (string-append (assoc-ref %build-inputs
- "vulkan-icd-loader") "/lib/libvulkan.so")))
- ;; Hard-code the path to libvulkan.so.
- (substitute* "dlls/vulkan/vulkan_thunks.c" (("libvulkan.so")
- libvulkan))
+ (let* ((source (assoc-ref %build-inputs "source"))
+ (script (string-append (assoc-ref %build-inputs
+ "wine-staging-patchset-data")
+ "/share/wine-staging/patches/patchinstall.sh")))
+ (invoke script (string-append "DESTDIR=" ".") "--all")
#t)))
(add-after 'install 'copy-wine32-binaries
(lambda* (#:key outputs #:allow-other-keys)