aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-15 13:23:40 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-15 13:23:40 +0200
commitff2bf8a2239a041b934690b91cb613c43d2963b9 (patch)
tree5221c7b012447ed147dc2ddd7c20a48728b06103
parent2708ae3d69b54d8323ca84fd9a7fb108a6ee96ba (diff)
downloadguix-ff2bf8a2239a041b934690b91cb613c43d2963b9.tar
guix-ff2bf8a2239a041b934690b91cb613c43d2963b9.tar.gz
gnu: python-jedi: Update to 0.17.0.
* gnu/packages/python-xyz.scm (python-jedi): Update to 0.17.0. [source](patches): Remove. * gnu/packages/patches/python-jedi-deleted-variables.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/python-jedi-deleted-variables.patch38
-rw-r--r--gnu/packages/python-xyz.scm5
3 files changed, 2 insertions, 42 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 65e51a3541..359b6db482 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1364,7 +1364,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-pep8-stdlib-tokenize-compat.patch \
%D%/packages/patches/python-pyfakefs-remove-bad-test.patch \
%D%/packages/patches/python-flint-includes.patch \
- %D%/packages/patches/python-jedi-deleted-variables.patch \
%D%/packages/patches/python-libxml2-utf8.patch \
%D%/packages/patches/python-mox3-python3.6-compat.patch \
%D%/packages/patches/python-testtools.patch \
diff --git a/gnu/packages/patches/python-jedi-deleted-variables.patch b/gnu/packages/patches/python-jedi-deleted-variables.patch
deleted file mode 100644
index 53bdc05cde..0000000000
--- a/gnu/packages/patches/python-jedi-deleted-variables.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-Fix test failure in some environments, including Guix.
-
-Taken from upstream:
-https://github.com/davidhalter/jedi/commit/bec87f7ff82b0731713c6520a14c213341b4cecf
-
-diff --git a/test/completion/basic.py b/test/completion/basic.py
-index b40068179..3ff919ca6 100644
---- a/test/completion/basic.py
-+++ b/test/completion/basic.py
-@@ -209,11 +209,11 @@ def global_as_import():
-
- deleted_var = 3
- del deleted_var
--#? int()
-+#?
- deleted_var
--#? ['deleted_var']
-+#? []
- deleted_var
--#! ['deleted_var = 3']
-+#! []
- deleted_var
-
- # -----------------
-diff --git a/test/test_api/test_full_name.py b/test/test_api/test_full_name.py
-index 4fdb861b0..6858b6ca8 100644
---- a/test/test_api/test_full_name.py
-+++ b/test/test_api/test_full_name.py
-@@ -112,7 +112,8 @@ def test_os_path(Script):
-
- def test_os_issues(Script):
- """Issue #873"""
-- assert [c.name for c in Script('import os\nos.nt''').complete()] == ['nt']
-+ # nt is not found, because it's deleted
-+ assert [c.name for c in Script('import os\nos.nt''').complete()] == []
-
-
- def test_param_name(Script):
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 009a0696c5..20b8784c05 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11912,15 +11912,14 @@ characters, mouse support, and auto suggestions.")
(define-public python-jedi
(package
(name "python-jedi")
- (version "0.16.0")
+ (version "0.17.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "jedi" version))
- (patches (search-patches "python-jedi-deleted-variables.patch"))
(sha256
(base32
- "1mb5kmrk9bkc3kwzx02j62cdan1jqd92q1z7h7wi9d30jg5p3j6m"))))
+ "0c1h9x3a9klvk2g288wl328x8xgzw7136k6vs9hkd56b85vcjh6z"))))
(build-system python-build-system)
(arguments
`(#:phases