aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-04-10 13:54:25 +0100
committerChristopher Baines <mail@cbaines.net>2020-04-16 09:28:05 +0100
commitad6bb60fa21547293ff2a30ac1e93609dd246b2a (patch)
treec1acfc720b1e2a84fd8ae4701943742a21287b5e
parent2ddbf4121580347d19913f06dc0d2413dbf937c3 (diff)
downloadguix-ad6bb60fa21547293ff2a30ac1e93609dd246b2a.tar
guix-ad6bb60fa21547293ff2a30ac1e93609dd246b2a.tar.gz
gnu: python2-dogtail: Switch to Python 3, and add Python 2 variant.
* gnu/packages/python-xyz.scm (python2-dogtail): Rename to python-dogtail. [name]: Change python2-dogtail to python-dogtail. [arguments]: Remove #:python. [propagated-inputs,native-inputs]: Switch Python 2 packages to Python 3 variants. (python2-dogtail): New variable.
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3dccedd6df..768f030051 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1736,11 +1736,9 @@ Python 3.3+.")
(delete-file "test/test_Script.py")
#t))))))))
-(define-public python2-dogtail
- ;; Python 2 only, as it leads to "TabError: inconsistent use of tabs and
- ;; spaces in indentation" with Python 3.
+(define-public python-dogtail
(package
- (name "python2-dogtail")
+ (name "python-dogtail")
(version "0.9.11")
(source (origin
(method url-fetch)
@@ -1753,8 +1751,7 @@ Python 3.3+.")
"0sr38z7b2n12bvfd4xw4b5dnnhkn5zl3h0ymmnnzavcihfqia6l0"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2
- #:tests? #f ; TODO Launching dbus for the tests
+ `(#:tests? #f ; TODO Launching dbus for the tests
; fails
#:phases
(modify-phases %standard-phases
@@ -1766,11 +1763,11 @@ Python 3.3+.")
(invoke "dbus-run-session" "--" "nosetests" "-v" "tests/"))
#t)))))
(propagated-inputs
- `(("python-pygobject" ,python2-pygobject)
- ("python-pycairo" ,python2-pycairo)
- ("python-pyatspi" ,python2-pyatspi)))
+ `(("python-pygobject" ,python-pygobject)
+ ("python-pycairo" ,python-pycairo)
+ ("python-pyatspi" ,python-pyatspi)))
(native-inputs
- `(("python-nose" ,python2-nose)
+ `(("python-nose" ,python-nose)
("gtk+" ,gtk+)
("xvfb" ,xorg-server)
("dbus" ,dbus)
@@ -1785,6 +1782,9 @@ applications. dogtail scripts are written in Python and executed like any
other Python program.")
(license license:gpl2+)))
+(define-public python2-dogtail
+ (package-with-python2 python-dogtail))
+
(define-public python-empy
(package
(name "python-empy")