aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-09-13 18:40:02 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-09-13 18:40:32 +0300
commitf21967a44bbd948846bdd1bbc370d3d0e3b52185 (patch)
tree5c4fe83c74892296c79452bd4214fa0e43bbfe4d
parentfade67ab756602bdeba508fbffa0e35234b58b9c (diff)
downloadguix-f21967a44bbd948846bdd1bbc370d3d0e3b52185.tar
guix-f21967a44bbd948846bdd1bbc370d3d0e3b52185.tar.gz
gnu: retroarch: Fix building on armhf-linux.
* gnu/packages/emulators.scm (retroarch)[arguments]: Add custom flags when building for armhf-linux.
-rw-r--r--gnu/packages/emulators.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index f21c322814..782bff5b18 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1066,7 +1066,7 @@ emulation community. It provides highly accurate emulation.")
(base32 "0h6y2hpjg4b470jvn9ghwp0k3a527sbb6xhia17frlm9w9v5028w"))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f ; no tests
+ `(#:tests? #f ; no tests
#:phases
(modify-phases %standard-phases
(replace 'configure
@@ -1086,10 +1086,14 @@ emulation community. It provides highly accurate emulation.")
(("<compat/zlib.h>") "<zlib.h>"))
;; The configure script does not yet accept the extra arguments
;; (like ‘CONFIG_SHELL=’) passed by the default configure phase.
- (zero? (system*
- "./configure"
- (string-append "--prefix=" out)
- (string-append "--global-config-dir=" etc)))))))))
+ (invoke
+ "./configure"
+ ,@(if (string-prefix? "armhf" (or (%current-target-system)
+ (%current-system)))
+ '("--enable-neon" "--enable-floathard")
+ '())
+ (string-append "--prefix=" out)
+ (string-append "--global-config-dir=" etc))))))))
(inputs
`(("alsa-lib" ,alsa-lib)
("ffmpeg" ,ffmpeg)