aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-11 20:23:50 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-13 19:53:08 +0200
commitf0314f65dfe31299fd2ef42f42d9691814f7856d (patch)
tree8848f389026f7572edfac51333d8d04998af186b
parent7ec4f648e5939e5dc10e1b28515dac8b03b63652 (diff)
downloadguix-f0314f65dfe31299fd2ef42f42d9691814f7856d.tar
guix-f0314f65dfe31299fd2ef42f42d9691814f7856d.tar.gz
gnu: Add perl-devel-checklib.
* gnu/packages/perl.scm (perl-devel-checklib): New public variable.
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 85604008e2..f556d19f3c 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2626,6 +2626,30 @@ the appropriate objects.")
particular command is available.")
(license (package-license perl))))
+(define-public perl-devel-checklib
+ (package
+ (name "perl-devel-checklib")
+ (version "1.13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/M/MA/MATTN/Devel-CheckLib-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1a19qkwxwz3wqb16cdabymfbf9kiydiifw90nd5srpq5hy8gvb94"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-io-captureoutput" ,perl-io-captureoutput)
+ ("perl-mock-config" ,perl-mock-config)))
+ (home-page "https://metacpan.org/release/Devel-CheckLib")
+ (synopsis "Check that a library is available")
+ (description
+ "@code{Devel::CheckLib} is a Perl module that checks whether a particular
+C library and its headers are available. You can also check for the presence of
+particular functions in a library, or even that those functions return
+particular results.")
+ (license perl-license)))
+
(define-public perl-devel-checkcompiler
(package
(name "perl-devel-checkcompiler")