aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-02-12 22:10:03 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-09-12 22:16:25 -0400
commitdcc31d7f41f5368a94a8478f634f1c7bda1c9b41 (patch)
tree5ca5dcf36816dff762faa154167007fe4ebaeed7
parent87e9fb5753c1d77b9630982e7bae9b54f23caecb (diff)
downloadguix-dcc31d7f41f5368a94a8478f634f1c7bda1c9b41.tar
guix-dcc31d7f41f5368a94a8478f634f1c7bda1c9b41.tar.gz
gnu: Add emacs-highlight-indentation.
* gnu/packages/emacs.scm (emacs-highlight-indentation): New variable.
-rw-r--r--gnu/packages/emacs.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index c6fcbde1ab..6df3aba4eb 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4592,6 +4592,30 @@ functions to assist in reviewing changes on files.")
environments (virtualenv) inside Emacs.")
(license license:gpl3+)))
+(define-public emacs-highlight-indentation
+ (package
+ (name "emacs-highlight-indentation")
+ (version "0.7.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/antonj/Highlight-Indentation-for-Emacs.git")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "00l54k75qk24a0znzl4ij3s3nrnr2wy9ha3za8apphzlm98m907k"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/antonj/Highlight-Indentation-for-Emacs/")
+ (synopsis "Highlighting indentation for Emacs")
+ (description "Provides two minor modes to highlight indentation guides in Emacs:
+@enumerate
+@item @code{highlight-indentation-mode}, which displays guidelines
+indentation (space indentation only).
+@item @code{highlight-indentation-current-column-mode}, which displays guidelines for the current-point indentation (space indentation only).
+@end enumerate")
+ (license license:gpl2+)))
+
(define-public emacs-rainbow-delimiters
(package
(name "emacs-rainbow-delimiters")