aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Brown <brown@fastmail.com>2018-09-13 08:54:36 -0500
committerLudovic Courtès <ludo@gnu.org>2018-09-14 11:23:07 +0200
commitdaa6036fda502460f626b7beb0afa93a0bac6d01 (patch)
tree97e44419af94ea5b748d3ff5f2c1bba9e1943a5e
parent1dd153b3aabcc05e2ed3863ea0571985c0cae307 (diff)
downloadguix-daa6036fda502460f626b7beb0afa93a0bac6d01.tar
guix-daa6036fda502460f626b7beb0afa93a0bac6d01.tar.gz
gnu: Add openblas-ilp64.
* gnu/packages/maths.scm (openblas-ilp64): New variable. Co-authored-by: Ludovic Courtès <ludovic.courtes@inria.fr>
-rw-r--r--gnu/packages/maths.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index af41093fbb..d3e72128ca 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -27,6 +27,7 @@
;;; Copyright © 2018 Nadya Voronova <voronovank@gmail.com>
;;; Copyright © 2018 Adam Massmann <massmannak@gmail.com>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018 Eric Brown <brown@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2873,6 +2874,18 @@ parts of it.")
"OpenBLAS is a BLAS library forked from the GotoBLAS2-1.13 BSD version.")
(license license:bsd-3)))
+(define-public openblas-ilp64
+ (package (inherit openblas)
+ (name "openblas-ilp64")
+ (supported-systems '("x86_64-linux" "aarch64-linux" "mips64el-linux"))
+ (arguments
+ (substitute-keyword-arguments (package-arguments openblas)
+ ((#:make-flags flags '())
+ `(append (list "INTERFACE64=1" "LIBNAMESUFFIX=ilp64")
+ ,flags))))
+ (synopsis "Optimized BLAS library based on GotoBLAS (ILP64 version)")
+ (license license:bsd-3)))
+
(define* (make-blis implementation #:optional substitutable?)
"Return a BLIS package with the given IMPLEMENTATION (see config/ in the
source tree for a list of implementations.)