aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpimi <madalinionel.patrascu@mdc-berlin.de>2018-09-06 17:14:50 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-13 15:07:45 +0200
commitd1ca3d7297f5d94dad6d9e2200d3d63738e45a2f (patch)
tree565efa83b76be223029ba0cd62dd1a1fd41051b6
parent26700caed91b967bf365e29eb576cc23b84a502f (diff)
downloadguix-d1ca3d7297f5d94dad6d9e2200d3d63738e45a2f.tar
guix-d1ca3d7297f5d94dad6d9e2200d3d63738e45a2f.tar.gz
gnu: Add r-svdialogs.
gnu/packages/cran.scm (r-svdialogs): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ab989abfff..721f43503a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5668,3 +5668,30 @@ Interfaces (GUI) in R. It is independent from any particular GUI widgets. It
centralizes info about GUI elements currently used, and it dispatches GUI
calls to the particular toolkits in use in function of the context.")
(license license:gpl2)))
+
+(define-public r-svdialogs
+ (package
+ (name "r-svdialogs")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "svDialogs" version))
+ (sha256
+ (base32 "0xqppydfawnwk84kb5qiybwbcmv38vn4imgz01mz2pnq4xb80p97"))))
+ (properties `((upstream-name . "svDialogs")))
+ (build-system r-build-system)
+ (inputs
+ `(("yad" ,yad)
+ ("zenity" ,zenity)))
+ (propagated-inputs
+ `(("r-rstudioapi" ,r-rstudioapi)
+ ("r-svgui" ,r-svgui)))
+ (home-page "https://github.com/SciViews/svDialogs/")
+ (synopsis "Portable dialog boxes")
+ (description
+ "This package helps to construct standard dialog boxes for your GUI, including
+message boxes, input boxes, list, file or directory selection, and others. In
+case R cannot display GUI dialog boxes, a simpler command line version of these
+interactive elements is also provided as a fallback solution.")
+ (license license:gpl2)))