aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpimi <madalinionel.patrascu@mdc-berlin.de>2018-09-03 16:59:46 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-13 22:16:01 +0200
commitb6afe7b7f540c0effbf570d72d5a1efb45287f01 (patch)
tree821a54e99a7e571f29b306f02fb8088e137d3547
parentf0314f65dfe31299fd2ef42f42d9691814f7856d (diff)
downloadguix-b6afe7b7f540c0effbf570d72d5a1efb45287f01.tar
guix-b6afe7b7f540c0effbf570d72d5a1efb45287f01.tar.gz
gnu: Add r-abnormality.
* gnu/packages/cran.scm (r-abnormality): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f8177da013..439cfcb014 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5797,3 +5797,28 @@ sampling and basic manipulation of Brazilian lawsuits identification number.
It also implements functions for text cleaning, such as accentuation
removal.")
(license license:expat)))
+
+(define-public r-abnormality
+ (package
+ (name "r-abnormality")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "abnormality" version))
+ (sha256
+ (base32 "1fzfskl9akl06nliy8hkv2a0pznpj8pwcypg3gj5r2nzvr3kan9v"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-mass" ,r-mass)
+ ("r-matrix" ,r-matrix)))
+ (home-page "https://cran.r-project.org/web/packages/abnormality/")
+ (synopsis "Measure a subject's abnormality with respect to a reference population")
+ (description
+ "This package contains functions to implement the methodology and
+considerations laid out by Marks et al. in the article \"Measuring abnormality
+in high dimensional spaces: applications in biomechanical gait analysis\".
+Using high-dimensional datasets to measure a subject's overall level of
+abnormality as compared to a reference population is often needed in outcomes
+research.")
+ (license license:expat)))