aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-12 17:16:37 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-13 19:53:08 +0200
commit7ec4f648e5939e5dc10e1b28515dac8b03b63652 (patch)
tree1ce68633b5164b305d776dd06b84a9fc9d0ee404
parent581b6f5e969e57a0ac7068685641afa205cc8308 (diff)
downloadguix-7ec4f648e5939e5dc10e1b28515dac8b03b63652.tar
guix-7ec4f648e5939e5dc10e1b28515dac8b03b63652.tar.gz
gnu: sg3_utils: Mark up description.
* gnu/packages/scsi.scm (sg3_utils)[description]: Use @dfn{}. Wrap commands in @command{} rather than @code{}, and @itemize them.
-rw-r--r--gnu/packages/scsi.scm27
1 files changed, 18 insertions, 9 deletions
diff --git a/gnu/packages/scsi.scm b/gnu/packages/scsi.scm
index 2bb863cad9..f011af84c4 100644
--- a/gnu/packages/scsi.scm
+++ b/gnu/packages/scsi.scm
@@ -40,15 +40,24 @@
(synopsis "SCSI device utilities")
(description
"sg3-utils is a collection of utilities for devices that use the Small
-Computer System Interface (SCSI) command set. It includes utilities to read
-data from, write data to, control, modify, and query the state of SCSI
-devices. For example, this package provides command-line tools to copy data
-based on @code{dd} syntax and semantics (called @code{sg_dd}, @code{sgp_dd}
-and @code{sgm_dd}), check INQUIRY data and VPD pages (@code{sg_inq}), check
-mode and log pages (@code{sginfo}, @code{sg_modes} and @code{sg_logs}), spin
-up and down disks (@code{sg_start}), do self tests (@code{sg_senddiag}), parse
-sense data (@code{sg_decode_sense}), and perform various other functions. In
-addition, this package includes a library, called libsgutils, which can be
+Computer System Interface (@dfn{SCSI}) command set. It includes utilities to
+read data from, write data to, control, modify, and query the state of SCSI
+devices.
+
+For example, this package provides command-line tools to:
+@itemize
+@item copy data based on @code{dd} syntax and semantics (called @command{sg_dd},
+@command{sgp_dd}, and @command{sgm_dd})
+@item check @code{INQUIRY} data and @code{VPD pages} (@command{sg_inq})
+@item check mode and log pages (@command{sginfo}, @command{sg_modes}, and
+@command{sg_logs})
+@item spin up and down disks (@command{sg_start})
+@item do self-tests (@code{sg_senddiag})
+@item parse sense data (@code{sg_decode_sense})
+@item and perform various other functions.
+@end itemize
+
+In addition, this package includes a library, called libsgutils, which can be
used in C and C++ programs to interact with SCSI devices.")
;; See README: "All utilities and libraries have either a "2 clause" BSD
;; license or are "GPL-2ed". [...] That BSD license was updated from the