aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-15 04:58:14 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-15 05:17:50 +0200
commit5c34d97187f8378249bf6a340ccde9e721a5a22d (patch)
tree3be56700e1a4a6841e1fb17e59a46554b2fbde42
parent61853b74473f0d191f1bcb43fcfcc1418093ac86 (diff)
downloadguix-5c34d97187f8378249bf6a340ccde9e721a5a22d.tar
guix-5c34d97187f8378249bf6a340ccde9e721a5a22d.tar.gz
gnu: pybind11: Don't use unstable tarball.
* gnu/packages/python.scm (pybind11)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/python.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b6dd3ebace..afb329654a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13784,14 +13784,14 @@ under Python 2.7.")
(name "pybind11")
(version "2.2.3")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/pybind/pybind11/archive/v"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pybind/pybind11.git")
+ (commit (string-append "v" version))))
(sha256
(base32
- "1sj0x4fwsbnwdai5sxpw1l1vh8m5hpbkfk3zanxcbcgs39jpnfrs"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ "111aagiy7lwf3gzf2hzg7sbgs2lxgj473bf75bqqfmhcbvf71vsq"))
+ (file-name (git-file-name name version))))
(build-system cmake-build-system)
(native-inputs
`(("python" ,python)