aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-15 06:14:29 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-15 12:15:28 +0200
commit4be83af4276328e04ab3c8a3c22ee8242adbbe71 (patch)
tree758d49a0e21597e2db7d2d57d114fcbdade37ca0
parent4e9832dd3865978a3d70f4e596e45e7d3398204d (diff)
downloadguix-4be83af4276328e04ab3c8a3c22ee8242adbbe71.tar
guix-4be83af4276328e04ab3c8a3c22ee8242adbbe71.tar.gz
gnu: gambit-c: Update to 4.9.0.
The tests makefile still contains the offending lines, but I was unable to reproduce the failure across 3 different machines. * gnu/packages/scheme.scm (gambit-c): Update to 4.9.0. [arguments]: Remove 'fix-tests' phase.
-rw-r--r--gnu/packages/scheme.scm17
1 files changed, 3 insertions, 14 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 7f26d71aa6..9654fe36f5 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -532,7 +532,7 @@ of libraries.")
(define-public gambit-c
(package
(name "gambit-c")
- (version "4.8.9")
+ (version "4.9.0")
(source
(origin
(method url-fetch)
@@ -542,24 +542,13 @@ of libraries.")
(string-map (lambda (c) (if (char=? c #\.) #\_ c)) version)
".tgz"))
(sha256
- (base32 "16sg1s8myzxqpimj5ry6lfza0qfs157zj28bvmxwwgy89jd9m5v7"))))
+ (base32 "19862w9ij0g5xrkskl4g89xbs17gp9cc6cfcdca6dlfkb3lk6xhp"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags
;; According to the ./configure script, this makes the build slower and
;; use >= 1 GB memory, but makes Gambit much faster.
- '("--enable-single-host")
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'fix-tests
- (lambda _
- (substitute* '("tests/makefile")
- ;; '-:' is how run-time options are set. 'tl' sets some terminal
- ;; option, which makes it fail in our build environment. It
- ;; recommends using 'd-' as a solution, which sets the REPL
- ;; interaction channel to stdin/stdout.
- (("gsi -:tl") "gsi -:d-,tl"))
- #t)))))
+ '("--enable-single-host")))
(home-page "http://gambitscheme.org")
(synopsis "Efficient Scheme interpreter and compiler")
(description