aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpimi <madalinionel.patrascu@mdc-berlin.de>2018-09-10 13:21:38 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-14 07:46:19 +0200
commit016cabf7bee007fb580d355113de8aa13d0f0a2b (patch)
treeffc191851d8f1dafd726744bfd57428c951fbbf2
parent317b139c5dc7e4501d79cd0952444b4b068bee5c (diff)
downloadguix-016cabf7bee007fb580d355113de8aa13d0f0a2b.tar
guix-016cabf7bee007fb580d355113de8aa13d0f0a2b.tar.gz
gnu: Add r-abodoutlier.
* gnu/packages/cran.scm (r-abodoutlier): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 439cfcb014..0c6a4908e8 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5822,3 +5822,32 @@ Using high-dimensional datasets to measure a subject's overall level of
abnormality as compared to a reference population is often needed in outcomes
research.")
(license license:expat)))
+
+(define-public r-abodoutlier
+ (package
+ (name "r-abodoutlier")
+ (version "0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "abodOutlier" version))
+ (sha256
+ (base32 "1pvhgxmh23br84r0fbmv7g53z2427birdja96a67vqgz18r3fdvj"))))
+ (properties `((upstream-name . "abodOutlier")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-cluster" ,r-cluster)))
+ (home-page "https://cran.r-project.org/web/packages/abodOutlier/")
+ (synopsis "Angle-based outlier detection")
+ (description
+ "This package performs angle-based outlier detection on a given data
+frame. It offers three methods to process data:
+@enumerate
+@item full but slow implementation using all the data that has cubic
+ complexity;
+@item a fully randomized method;
+@item a method using k-nearest neighbours.
+@end enumerate
+These algorithms are well suited for high dimensional data outlier
+detection.")
+ (license license:expat)))