aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 12:01:50 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-28 11:21:18 +0000
commitf5fa519202e87b16e7db36bb35dd1eddef935fb7 (patch)
tree47eb2b5cadd41892c138a0d650dbc43b6d753662
parent7992c51e7db4761101de740a4f7fccc02e0bd127 (diff)
downloadguix-f5fa519202e87b16e7db36bb35dd1eddef935fb7.tar
guix-f5fa519202e87b16e7db36bb35dd1eddef935fb7.tar.gz
gnu: Add ruby-vcr.
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 03d05045d8..95b63c4217 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5027,6 +5027,28 @@ support to both Ruby and JRuby. It uses @code{unf_ext} on CRuby and
"http://github.com/janlelis/unicode-display_width")
(license license:expat)))
+(define-public ruby-vcr
+ (package
+ (name "ruby-vcr")
+ (version "3.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "vcr" version))
+ (sha256
+ (base32
+ "1y19gb8vz1rbhx1qhim6kpp0fzksqhd7grb50hmrbjx5h4hc3y0y"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; No Rakefile in gem, and there's likely unpackaged
+ ; dependencies anyway.
+ (synopsis
+ "Record your test suite's HTTP interactions and replay them during future test runs for fast, deterministic, accurate tests.")
+ (description
+ "Record your test suite's HTTP interactions and replay them during future test runs for fast, deterministic, accurate tests.")
+ (home-page "http://vcr.github.io/vcr")
+ (license license:expat)))
+
(define-public ruby_version ; There is another gem called 'ruby-version' so we
; use an underscore in this name
(package