aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 12:01:07 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-28 11:21:19 +0000
commitca0c5c467dc3ead164caeff681dd92afdd7ed2b9 (patch)
treece78c69a9bcd5c48ac06b17d22b51c2745b80511
parentca51b1f3ed7dddfeecdcfbf2535a68324f446ef1 (diff)
downloadguix-ca0c5c467dc3ead164caeff681dd92afdd7ed2b9.tar
guix-ca0c5c467dc3ead164caeff681dd92afdd7ed2b9.tar.gz
gnu: Add ruby-rubygems.
-rw-r--r--gnu/packages/ruby.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e37adcf90f..4de2962893 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8044,3 +8044,33 @@ but it can function as a stand-alone templating engine.")
(home-page
"https://github.com/jeremyevans/erubi")
(license license:expat)))
+
+(define-public ruby-rubygems
+ (package
+ (name "ruby-rubygems")
+ (version (string-append "2.6.6"))
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://rubygems.org/rubygems/rubygems-"
+ version ".tgz"))
+ (sha256
+ (base32
+ "0x0ldlwr627d0brw96jdbscib6d2nk19izvnh8lzsasszi1k5rkq"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'build
+ (lambda* (#:key outputs #:allow-other-keys)
+ (zero? (system*
+ "ruby" "setup.rb"
+ (string-append
+ "--prefix=" (assoc-ref outputs "out"))))))
+ (delete 'check) ; fix
+ (delete 'install) ; done in build
+ )))
+ (synopsis "")
+ (description
+ "")
+ (home-page "")
+ (license license:expat))) ;?