aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:49:24 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-28 11:21:19 +0000
commit908c9322daaddf48b77dd08f33d157260c150cd0 (patch)
tree2c65dcb6a0569411e06c2ea39f620cb29cf1e590
parentf293b6a876e3f9f727c5712b7cd5abcb35741c25 (diff)
downloadguix-908c9322daaddf48b77dd08f33d157260c150cd0.tar
guix-908c9322daaddf48b77dd08f33d157260c150cd0.tar.gz
gnu: Add ruby-haml.
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 90e76e1858..cccfa8403c 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7641,3 +7641,28 @@ implementation of maps/hashes that use references and a reference queue.")
(home-page
"http://github.com/ruby-concurrency/ref")
(license license:expat)))
+
+;; haml 4 cannot currently be packaged because tilt is not yet packaged.
+(define-public ruby-haml
+ (package
+ (name "ruby-haml")
+ (version "4.0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "haml" version))
+ (sha256
+ (base32
+ "0mrzjgkygvfii66bbylj2j93na8i89998yi01fin3whwqbvx0m1p"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; circular dependency with tilt
+; (propagated-inputs `(("ruby-tilt" ,ruby-tilt)))
+ (synopsis "Haml (HTML Abstraction Markup Language) library.")
+ (description
+ "Haml (HTML Abstraction Markup Language) is a layer on top of HTML or XML
+that is designed to express the structure of documents using indentation rather
+than closing tags. It was originally envisioned as a plugin for Ruby on Rails,
+but it can function as a stand-alone templating engine.")
+ (home-page "http://haml.info/")
+ (license license:expat)))