aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 12:02:25 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-28 11:21:19 +0000
commit859a111d7aad55dff8d9e03cf0595fe62ffae225 (patch)
tree4f971f08abea59e89855700e89fe62514b921d08
parentca0c5c467dc3ead164caeff681dd92afdd7ed2b9 (diff)
downloadguix-859a111d7aad55dff8d9e03cf0595fe62ffae225.tar
guix-859a111d7aad55dff8d9e03cf0595fe62ffae225.tar.gz
gnu: Add ruby-ruby-dep.
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 4de2962893..4516d34c88 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8074,3 +8074,24 @@ but it can function as a stand-alone templating engine.")
"")
(home-page "")
(license license:expat))) ;?
+
+(define-public ruby-ruby-dep
+ (package
+ (name "ruby-ruby-dep")
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "ruby_dep" version))
+ (sha256
+ (base32
+ "12i57gpy0gmkwnd7l6xdjpfw9bygxmgwx4hjwgg4mca2jr7d3g47"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; Do not test to avoid circular dependency with gem_isolator.
+ (synopsis
+ "Creates a version constraint of supported Rubies,suitable for a gemspec file")
+ (description
+ "Creates a version constraint of supported Rubies,suitable for a gemspec file")
+ (home-page "https://github.com/e2/ruby_dep")
+ (license license:expat)))