aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:43:27 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-28 11:21:18 +0000
commit6cebcca0b5401bbe64ac4141c40d59a8eaa8c7c1 (patch)
tree98f5764a3660dfd96b5e5b8bc85c00f1afacacd0
parent5c32a94f3122ce5579a983693fb36f28e22ba229 (diff)
downloadguix-6cebcca0b5401bbe64ac4141c40d59a8eaa8c7c1.tar
guix-6cebcca0b5401bbe64ac4141c40d59a8eaa8c7c1.tar.gz
gnu: Add ruby-radius.
-rw-r--r--gnu/packages/ruby.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e8ee084a1c..b1d1b6912e 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4351,6 +4351,47 @@ clickjacking, directory traversal, session hijacking and IP spoofing.")
(home-page "https://github.com/sinatra/sinatra/tree/master/rack-protection")
(license license:expat)))
+(define-public ruby-radius
+ (package
+ (name "ruby-radius")
+ (version "0.7.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "radius" version))
+ (sha256
+ (base32
+ "0n0clzgvxpjm2gjlpz98x6gkw5hb84bmd435a1yaqs3m0k896v5s"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ ;; TODO: There are two .gem files in the source, and the build system
+ ;; seems to get confused, and attempts to remove the wrong one (I
+ ;; think)...
+ ;;
+ ;; For now, workaround the issue, by creating the file the install
+ ;; phase in the build system tries to remove.
+ (add-before 'install 'workaround-gem-removal
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((directory (string-append
+ (assoc-ref outputs "out")
+ "/lib/ruby/vendor_ruby/cache/pkg")))
+ (mkdir-p directory)
+ (with-output-to-file
+ (string-append directory "/radius-0.7.0.prerelease.gem")
+ (lambda _ (display "")))))))))
+ (native-inputs
+ `(("ruby-simplecov" ,ruby-simplecov)
+ ("ruby-kramdown" ,ruby-kramdown)
+ ("ruby-coveralls" ,ruby-coveralls)))
+ (synopsis
+ "Radius is a powerful tag-based template language for Ruby inspired by the template languages used in MovableType and TextPattern. It uses tags similar to XML, but can be used to generate any form of plain text (HTML, e-mail, etc...).")
+ (description
+ "Radius is a powerful tag-based template language for Ruby inspired by the template languages used in MovableType and TextPattern. It uses tags similar to XML, but can be used to generate any form of plain text (HTML, e-mail, etc...).")
+ (home-page "http://github.com/jlong/radius")
+ (license #f)))
+
(define-public ruby-rainbow
(package
(name "ruby-rainbow")