aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:44:44 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-28 11:21:18 +0000
commit44d2b2bc36138a1a161aa09d506aca7af54cd34d (patch)
tree679f572abd63bba89e228be72f771cb863e01ee8
parent463aff0ed9cc2f8fc74dbf474ed1115b20b0cd7a (diff)
downloadguix-44d2b2bc36138a1a161aa09d506aca7af54cd34d.tar
guix-44d2b2bc36138a1a161aa09d506aca7af54cd34d.tar.gz
gnu: Improve ruby-hashie.
-rw-r--r--gnu/packages/ruby.scm50
1 files changed, 38 insertions, 12 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 6f2bc73baa..677d39800d 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6573,21 +6573,47 @@ is compatible with stylesheets designed for pygments.")
(define-public ruby-hashie
(package
(name "ruby-hashie")
- (version "3.6.0")
- (source (origin
- (method url-fetch)
- (uri (rubygems-uri "hashie" version))
- (sha256
- (base32
- "13bdzfp25c8k51ayzxqkbzag3wj5gc1jd8h7d985nsq6pn57g5xh"))))
+ (version "3.5.7")
+ (source
+ (origin
+ (method url-fetch)
+ ;; The gem does not include Gemfile.
+ (uri (string-append "https://github.com/intridea/hashie/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "00afsf591jj1q7j44fswwwrki01qgxa6wnqi6a6sq3bfjm1jlxy6"))))
(build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f
+ #:test-target "spec"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'fix-dependencies
+ (lambda _
+ (substitute* "Gemfile"
+ ((".*pry.*") "")
+ ((".*guard.*") "")
+ ((".*codeclimate.*") "")
+ (("rubocop.*") "rubocop'\n")
+ (("rspec-core.*") "rspec-core'\n"))
+ (substitute* "spec/spec_helper.rb"
+ ((".*pry.*") ""))
+ #t)))))
(native-inputs
- `(("bundler" ,bundler)))
- (arguments `(#:tests? #f)); FIXME: Could not locate Gemfile or .bundle/ directory
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec)
+ ("ruby-rspec-pending-for" ,ruby-rspec-pending-for)
+ ;("ruby-guard" ,ruby-guard)
+ ;("ruby-guard-rspec" ,ruby-guard-rspec)
+ ("ruby-activesupport" ,ruby-activesupport)
+ ("ruby-rubocop" ,ruby-rubocop)))
+ (synopsis
+ "Hashie is a collection of classes and mixins that make hashes more powerful.")
+ (description
+ "Hashie is a collection of classes and mixins that make hashes more powerful.")
(home-page "https://github.com/intridea/hashie")
- (synopsis "Extensions to Ruby Hashes")
- (description "Hashie is a collection of classes and mixins that make Ruby
-hashes more powerful.")
(license license:expat)))
(define-public ruby-heredoc-unindent