aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 12:00:55 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-28 11:21:18 +0000
commit2c76758a655552e6178f3e534df09b667dfc9bb5 (patch)
tree4fc087b4b311f06ef83a0d5872e1d4b6cd05653e
parent1594f527196fbd59e8c99809dd1e18ef1a31a36f (diff)
downloadguix-2c76758a655552e6178f3e534df09b667dfc9bb5.tar
guix-2c76758a655552e6178f3e534df09b667dfc9bb5.tar.gz
gnu: Add ruby-redjs.
-rw-r--r--gnu/packages/ruby.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e0768b6b2f..2b2f1b586b 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4552,6 +4552,38 @@ clickjacking, directory traversal, session hijacking and IP spoofing.")
(home-page "https://github.com/sickill/rainbow")
(license license:expat)))
+(define-public ruby-redjs
+ ;; There are no releases on rubygems and the last git commit was in 2012, so
+ ;; we package that.
+ (let ((commit "0d844f066666f967a78b20beb164c52d9ac3f5ca"))
+ (package
+ (name "ruby-redjs")
+ (version (string-append "0.4.6-1." (string-take commit 8)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cowboyd/redjs.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0cl3543xnzfn5qvlwjl2g1gg0jm6mfa75ag9qh89pfay7b0mxz7i"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'replace-git-ls-files
+ (lambda _
+ (substitute* "redjs.gemspec"
+ (("git ls-files") "find . -type f |sort"))
+ #t)))))
+ (synopsis "")
+ (description
+ "")
+ (home-page "")
+ (license license:expat)))) ;?
+
(define-public ruby-rubocop
(package
(name "ruby-rubocop")