aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-18 22:15:31 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-28 11:21:18 +0000
commit1594f527196fbd59e8c99809dd1e18ef1a31a36f (patch)
tree0979427c08541c1ff5920a68b14ebb19626d31ea
parent35f94a1b3afbc525782f5b1a947308e01c0efb08 (diff)
downloadguix-1594f527196fbd59e8c99809dd1e18ef1a31a36f.tar
guix-1594f527196fbd59e8c99809dd1e18ef1a31a36f.tar.gz
gnu: Add ruby-ref.
-rw-r--r--gnu/packages/ruby.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 18c30bf416..e0768b6b2f 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7543,3 +7543,33 @@ way.")
(home-page
"http://github.com/rails/ruby-coffee-script")
(license license:expat)))
+
+(define-public ruby-ref
+ (package
+ (name "ruby-ref")
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ ;; Tests are not distributed at rubygems.org so download from GitHub
+ ;; instead.
+ (uri (string-append "https://github.com/ruby-concurrency/ref/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1090z8vzf8bf7gx3akvrn4alcklyanbg6hipjmzlzkx0lr1l5zj4"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:test-target "spec"))
+ (synopsis
+ "Library that implements weak, soft, and strong references in Ruby that work
+across multiple runtimes (MRI, Jruby and Rubinius). Also includes implementation
+of maps/hashes that use references and a reference queue.")
+ (description
+ "Library that implements weak, soft, and strong references in Ruby that work
+across multiple runtimes (MRI, Jruby and Rubinius). Also includes
+implementation of maps/hashes that use references and a reference queue.")
+ (home-page
+ "http://github.com/ruby-concurrency/ref")
+ (license license:expat)))