aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-02-05 19:53:02 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-02-05 19:54:10 +0200
commitfd3638d89a4aec8791ca415f8012b9094d1fc5f4 (patch)
tree4bd882ed8f34b251de8fa9e39412e8f63d535fd4
parentea4b6ffd24f6656b31d2c037a5671748ac6a81c0 (diff)
downloadguix-fd3638d89a4aec8791ca415f8012b9094d1fc5f4.tar
guix-fd3638d89a4aec8791ca415f8012b9094d1fc5f4.tar.gz
gnu: python-sh: Use custom 'check phase.
* gnu/packages/python-xyz.scm (python-sh)[arguments]: Use custom 'check phase as suggested by upstream documentation. [native-inputs]: Add python-coverage.
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ef8565d7bf..a8239792f6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -445,6 +445,14 @@ concepts.")
(base32
"1z2hx357xp3v4cv44xmqp7lli3frndqpyfmpbxf7n76h7s1zaaxm"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "python" "sh.py" "test"))))))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)))
(home-page "https://github.com/amoffat/sh")
(synopsis "Python subprocess replacement")
(description "This package provides a replacement for Python's