aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-02-01 19:02:36 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-02-05 22:34:13 +0100
commitd13b9c5f67c3ce7c03b58bad78ebbf80a8427dda (patch)
tree3d690d63449ed4445b5c2d54cafbdc69dc73aad1
parent48ad1181d0f09af86d26cfdbc99461968092b466 (diff)
downloadguix-d13b9c5f67c3ce7c03b58bad78ebbf80a8427dda.tar
guix-d13b9c5f67c3ce7c03b58bad78ebbf80a8427dda.tar.gz
gnu: Add ocaml-ppx-base.
* gnu/packages/ocaml.scm (ocaml-ppx-base): New variable.
-rw-r--r--gnu/packages/ocaml.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 5f4595d70e..c9df13dc28 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5841,3 +5841,35 @@ packages.")
(description "This package can automatically generate runtime types
from type definitions.")
(license license:asl2.0)))
+
+(define-public ocaml-ppx-base
+ (package
+ (name "ocaml-ppx-base")
+ (version "0.11.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
+ (version-major+minor version)
+ "/files/ppx_base-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "0aq206pg330jmj7lhcagiiwm3a0b3gsqm801m8ajd4ysyw7idkym"))))
+ (build-system dune-build-system)
+ (arguments
+ `(#:test-target "."))
+ (propagated-inputs
+ `(("ocaml-ppx-compare" ,ocaml-ppx-compare)
+ ("ocaml-ppx-enumerate" ,ocaml-ppx-enumerate)
+ ("ocaml-ppx-hash" ,ocaml-ppx-hash)
+ ("ocaml-ppx-js-style" ,ocaml-ppx-js-style)
+ ("ocaml-ppx-sexp-conv" ,ocaml-ppx-sexp-conv)
+ ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+ ("ocaml-ppxlib" ,ocaml-ppxlib)))
+ (properties `((upstream-name . "ppx_base")))
+ (home-page "https://github.com/janestreet/ppx_base")
+ (synopsis "Base set of ppx rewriters")
+ (description "Ppx_base is the set of ppx rewriters used for Base.
+
+Note that Base doesn't need ppx to build, it is only used as a
+verification tool.")
+ (license license:asl2.0)))