aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-02-01 16:54:57 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-02-05 22:33:25 +0100
commitc7cf165e38ed8e24c7199d8a27ceefb4cf4afd5b (patch)
tree4e7bca6d428dc2ef5595e9a17ed10ff056249890
parent7b685486ce3f6e697830bf05e6dd4b47343b4eae (diff)
downloadguix-c7cf165e38ed8e24c7199d8a27ceefb4cf4afd5b.tar
guix-c7cf165e38ed8e24c7199d8a27ceefb4cf4afd5b.tar.gz
gnu: Add ocaml-ppx-sexp-conv.
* gnu/packaes/ocaml.scm (ocaml-ppx-sexp-conv): New variable.
-rw-r--r--gnu/packages/ocaml.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 35c0fb59ec..f432baa111 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5275,3 +5275,28 @@ first class values representing record fields, and additional routines, to get
and set record fields, iterate and fold over all fields of a record and create
new record values.")
(license license:asl2.0)))
+
+(define-public ocaml-ppx-sexp-conv
+ (package
+ (name "ocaml-ppx-sexp-conv")
+ (version "0.11.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/janestreet/ppx_sexp_conv.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pqwnqy1xp309wvdcaax4lg02yk64lq2w03mbgfvf6ps5ry4gis9"))))
+ (build-system dune-build-system)
+ (propagated-inputs
+ `(("ocaml-base" ,ocaml-base)
+ ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+ ("ocaml-ppxlib" ,ocaml-ppxlib)))
+ (properties `((upstream-name . "ppx_sexp_conv")))
+ (home-page "https://github.com/janestreet/ppx_sexp_conv")
+ (synopsis "Generation of S-expression conversion functions from type definitions")
+ (description "This package generates S-expression conversion functions from type
+definitions.")
+ (license license:asl2.0)))