aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-02-03 17:57:36 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-02-05 22:34:31 +0100
commit8baa5c8b7c9aa1d85726778d1a44d11e2791388b (patch)
tree5b589d785fd7cd22ea5985b68b3b2b16e2ba68b2
parent514b542018e85d724e6163faf2fab314d9a9e492 (diff)
downloadguix-8baa5c8b7c9aa1d85726778d1a44d11e2791388b.tar
guix-8baa5c8b7c9aa1d85726778d1a44d11e2791388b.tar.gz
gnu: Add ocaml-core-kernel.
* gnu/packages/ocaml.scm (ocaml-core-kernel): New variable.
-rw-r--r--gnu/packages/ocaml.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 43467da1a0..3f324ed226 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6110,3 +6110,52 @@ standard library that was developed by Jane Street.")
;; Also contains parts of OCaml, relicensed to asl2.0, as permitted
;; by OCaml's license for consortium members (see THIRD-PARTY.txt).
(license license:asl2.0)))
+
+(define-public ocaml-core-kernel
+ (package
+ (name "ocaml-core-kernel")
+ (version "0.11.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/janestreet/core_kernel.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1dg7ygy7i64c5gaakb1cp1b26p9ks81vbxmb8fd7jff2q60j2z2g"))))
+ (build-system dune-build-system)
+ (arguments
+ ;; Cyclic dependency with ocaml-core
+ `(#:tests? #f))
+ (propagated-inputs
+ `(("ocaml-base" ,ocaml-base)
+ ("ocaml-bin-prot" ,ocaml-bin-prot)
+ ("ocaml-configurator" ,ocaml-configurator)
+ ("ocaml-fieldslib" ,ocaml-fieldslib)
+ ("ocaml-jane-street-headers" ,ocaml-jane-street-headers)
+ ("ocaml-ppx-assert" ,ocaml-ppx-assert)
+ ("ocaml-ppx-base" ,ocaml-ppx-base)
+ ("ocaml-ppx-hash" ,ocaml-ppx-hash)
+ ("ocaml-ppx-inline-test" ,ocaml-ppx-inline-test)
+ ("ocaml-ppx-jane" ,ocaml-ppx-jane)
+ ("ocaml-ppx-sexp-conv" ,ocaml-ppx-sexp-conv)
+ ("ocaml-ppx-sexp-message" ,ocaml-ppx-sexp-message)
+ ("ocaml-sexplib" ,ocaml-sexplib)
+ ("ocaml-splittable-random" ,ocaml-splittable-random)
+ ("ocaml-stdio" ,ocaml-stdio)
+ ("ocaml-typerep" ,ocaml-typerep)
+ ("ocaml-variantslib" ,ocaml-variantslib)
+ ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)))
+ (properties `((upstream-name . "core_kernel")))
+ (home-page "https://github.com/janestreet/core_kernel")
+ (synopsis "Portable standard library for OCaml")
+ (description "Core is an alternative to the OCaml standard library.
+
+Core_kernel is the system-independent part of Core. It is aimed for cases when
+the full Core is not available, such as in Javascript.")
+ (license (list
+ ;; this package and parts of OCaml, relicensed by janestreet
+ license:asl2.0
+ ;; MLton and sjs
+ license:expat))))