aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-02-01 19:06:12 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-02-05 22:34:15 +0100
commit7bd4b85e9bbb70687129721c9bdb2cf0576c715c (patch)
tree1b926a43c1f4127fd92781e1ffda066a7db54b8d
parentd13b9c5f67c3ce7c03b58bad78ebbf80a8427dda (diff)
downloadguix-7bd4b85e9bbb70687129721c9bdb2cf0576c715c.tar
guix-7bd4b85e9bbb70687129721c9bdb2cf0576c715c.tar.gz
gnu: Add ocaml-ppx-bin-prot.
* gnu/packages/ocaml.scm (ocaml-ppx-bin-prot): New variable.
-rw-r--r--gnu/packages/ocaml.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c9df13dc28..cbcb225c78 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5873,3 +5873,33 @@ from type definitions.")
Note that Base doesn't need ppx to build, it is only used as a
verification tool.")
(license license:asl2.0)))
+
+(define-public ocaml-ppx-bin-prot
+ (package
+ (name "ocaml-ppx-bin-prot")
+ (version "0.11.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/janestreet/ppx_bin_prot.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1h60i75bzvhna1axyn662gyrzhh441l79vl142d235i5x31dmnkz"))))
+ (build-system dune-build-system)
+ (arguments
+ ;; Cyclic dependency with ocaml-ppx-jane
+ `(#:tests? #f))
+ (propagated-inputs
+ `(("ocaml-base" ,ocaml-base)
+ ("ocaml-bin-prot" ,ocaml-bin-prot)
+ ("ocaml-ppx-here" ,ocaml-ppx-here)
+ ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+ ("ocaml-ppxlib" ,ocaml-ppxlib)))
+ (properties `((upstream-name . "ppx_bin_prot")))
+ (home-page "https://github.com/janestreet/ppx_bin_prot")
+ (synopsis "Generation of bin_prot readers and writers from types")
+ (description "Generation of binary serialization and deserialization
+functions from type definitions.")
+ (license license:asl2.0)))