aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2019-02-06 16:12:38 -0600
committerEric Bavier <bavier@member.fsf.org>2019-02-07 21:20:47 -0600
commit7b84610e2113d634c962020e4715a34518060918 (patch)
tree1198ad04d7a3c55c1ca2e7ac9a6b8c864fa68566
parent7fedc3fdfb5fba8098c08d04a7d0cb7131c24a79 (diff)
downloadguix-7b84610e2113d634c962020e4715a34518060918.tar
guix-7b84610e2113d634c962020e4715a34518060918.tar.gz
gnu: hdf5: Upgrade to 1.8.21.
* gnu/packages/maths.scm (hdf5): Upgrade to 1.8.21. [source]: Make version manipulations more readable using match.
-rw-r--r--gnu/packages/maths.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 402b53ca0e..074e878de4 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -749,7 +749,7 @@ incompatible with HDF5.")
(define-public hdf5
(package
(name "hdf5")
- (version "1.8.19")
+ (version "1.8.21")
(source
(origin
(method url-fetch)
@@ -759,11 +759,12 @@ incompatible with HDF5.")
version ".tar.bz2")
(string-append "https://support.hdfgroup.org/ftp/HDF5/"
"current"
- (apply string-append
- (take (string-split version #\.) 2))
+ (match (string-split version #\.)
+ ((major minor _ ...)
+ (string-append major minor)))
"/src/hdf5-" version ".tar.bz2")))
(sha256
- (base32 "0f3jfbqpaaq21ighi40qzs52nb52kc2d2yjk541rjmsx20b3ih2r"))
+ (base32 "03glk4w4wyb1jyb443g53y3y1ncnf6mj2cqwm6avfr2awkgb3cg5"))
(patches (search-patches "hdf5-config-date.patch"
"hdf5-1.8-mpi-deprecations.patch"))))
(build-system gnu-build-system)