aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-02-01 16:52:25 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-02-05 22:33:23 +0100
commit7b685486ce3f6e697830bf05e6dd4b47343b4eae (patch)
treed7176f68dec2878aef082bd8c54d1858bc00ae03
parentd9f8433e170d7024a1763a2983db4f357acf81fa (diff)
downloadguix-7b685486ce3f6e697830bf05e6dd4b47343b4eae.tar
guix-7b685486ce3f6e697830bf05e6dd4b47343b4eae.tar.gz
gnu: Add ocaml-ppx-fields-conv.
* gnu/packages/ocaml.scm (ocaml-ppx-fields-conv): New variable.
-rw-r--r--gnu/packages/ocaml.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 08ead1d952..35c0fb59ec 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5248,3 +5248,30 @@ of a record and create new record values.")
(description "The Core suite of libraries is an alternative to OCaml's
standard library.")
(license license:asl2.0)))
+
+(define-public ocaml-ppx-fields-conv
+ (package
+ (name "ocaml-ppx-fields-conv")
+ (version "0.11.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
+ (version-major+minor version)
+ "/files/ppx_fields_conv-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "07zrd3qky2ppbfl55gpm90rvqa5860xgwcsvihrjmkrw6d0jirkc"))))
+ (build-system dune-build-system)
+ (propagated-inputs
+ `(("ocaml-base" ,ocaml-base)
+ ("ocaml-fieldslib" ,ocaml-fieldslib)
+ ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+ ("ocaml-ppxlib" ,ocaml-ppxlib)))
+ (properties `((upstream-name . "ppx_fields_conv")))
+ (home-page "https://github.com/janestreet/ppx_fields_conv")
+ (synopsis "Generation of accessor and iteration functions for ocaml records")
+ (description "Ppx_fields_conv is a ppx rewriter that can be used to define
+first class values representing record fields, and additional routines, to get
+and set record fields, iterate and fold over all fields of a record and create
+new record values.")
+ (license license:asl2.0)))