aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-02-01 18:30:08 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-02-05 22:33:58 +0100
commit79967eeafc17e40594220cc3113959ac4b9deb37 (patch)
tree7c653c299638b218359aeccb424b34a636f2abe3
parent3f4ecf6649b733d50b11acb941d16b7505fdb93e (diff)
downloadguix-79967eeafc17e40594220cc3113959ac4b9deb37.tar
guix-79967eeafc17e40594220cc3113959ac4b9deb37.tar.gz
gnu: add ocaml-ppx-optcomp.
* gnu/packages/ocaml.scm (ocaml-ppx-optcomp): New variable.
-rw-r--r--gnu/packages/ocaml.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 7f208a8888..6a56c712d5 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5644,3 +5644,28 @@ context such as function arguments.")
"A ppx rewriter that rewrites simple match statements with an if then
else expression.")
(license license:asl2.0)))
+
+(define-public ocaml-ppx-optcomp
+ (package
+ (name "ocaml-ppx-optcomp")
+ (version "0.11.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
+ (version-major+minor version)
+ "/files/ppx_optcomp-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "1bb52p2j2h4s9f06vrcpla80rj93jinnzq6jzilapyx9q068929i"))))
+ (build-system dune-build-system)
+ (propagated-inputs
+ `(("ocaml-base" ,ocaml-base)
+ ("ocaml-stdio" ,ocaml-stdio)
+ ("ocaml-ppxlib" ,ocaml-ppxlib)))
+ (properties `((upstream-name . "ppx_optcomp")))
+ (home-page "https://github.com/janestreet/ppx_optcomp")
+ (synopsis "Optional compilation for OCaml")
+ (description "Ppx_optcomp stands for Optional Compilation. It is a tool
+used to handle optional compilations of pieces of code depending of the word
+size, the version of the compiler, ...")
+ (license license:asl2.0)))