aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-02-01 18:44:22 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-02-05 22:34:07 +0100
commit4e4e5fb1dfed2c9c55486e09bb4a39e7e40aee1a (patch)
tree573088630392f89c1877501fafb9c6e05b07ef5f
parent7ec9a45db3ad4b57bf6fc94ad25b8f6f091e5c0e (diff)
downloadguix-4e4e5fb1dfed2c9c55486e09bb4a39e7e40aee1a.tar
guix-4e4e5fb1dfed2c9c55486e09bb4a39e7e40aee1a.tar.gz
gnu: Add ocaml-ppx-expect.
* gnu/packages/ocaml.scm (ocaml-ppx-expect): New variable.
-rw-r--r--gnu/packages/ocaml.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c106229552..20766790f0 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5745,3 +5745,43 @@ position.")
(description "This package contains assert-like extension nodes that raise
useful errors on failure.")
(license license:asl2.0)))
+
+(define-public ocaml-ppx-expect
+ (package
+ (name "ocaml-ppx-expect")
+ (version "0.11.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/janestreet/ppx_expect.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0bnz3cpj3vwdw409r6f8raakl8n364q5l7wy4i6gckr34a4vla69"))))
+ (build-system dune-build-system)
+ (arguments
+ `(#:jbuild? #t))
+ (propagated-inputs
+ `(("ocaml-base" ,ocaml-base)
+ ("ocaml-ppx-assert" ,ocaml-ppx-assert)
+ ("ocaml-ppx-compare" ,ocaml-ppx-compare)
+ ("ocaml-ppx-custom-printf" ,ocaml-ppx-custom-printf)
+ ("ocaml-ppx-fields-conv" ,ocaml-ppx-fields-conv)
+ ("ocaml-ppx-here" ,ocaml-ppx-here)
+ ("ocaml-ppx-inline-test" ,ocaml-ppx-inline-test)
+ ("ocaml-ppx-sexp-conv" ,ocaml-ppx-sexp-conv)
+ ("ocaml-ppx-variants-conv" ,ocaml-ppx-variants-conv)
+ ("ocaml-stdio" ,ocaml-stdio)
+ ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+ ("ocaml-ppxlib" ,ocaml-ppxlib)
+ ("ocaml-re" ,ocaml-re)))
+ (properties `((upstream-name . "ppx_expect")))
+ (home-page "https://github.com/janestreet/ppx_expect")
+ (synopsis "Cram like framework for OCaml")
+ (description "Expect-test is a framework for writing tests in OCaml, similar
+to Cram. Expect-tests mimics the existing inline tests framework with the
+@code{let%expect_test} construct. The body of an expect-test can contain
+output-generating code, interleaved with @code{%expect} extension expressions
+to denote the expected output.")
+ (license license:asl2.0)))