aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-02-01 18:58:33 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-02-05 22:34:11 +0100
commit48ad1181d0f09af86d26cfdbc99461968092b466 (patch)
tree2f3693eab0856cdce430bafb98cf500ef08f515c
parentf4304c1d6c3a89b0b01104964b06b95a1e4e94cf (diff)
downloadguix-48ad1181d0f09af86d26cfdbc99461968092b466.tar
guix-48ad1181d0f09af86d26cfdbc99461968092b466.tar.gz
gnu: Add ocaml-ppx-typerep-conv.
* gnu/packages/ocaml.scm (ocaml-ppx-typerep-conv): New variable.
-rw-r--r--gnu/packages/ocaml.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c07585743c..5f4595d70e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5814,3 +5814,30 @@ to denote the expected output.")
@code{lint} tool to enforce some coding conventions across all Jane Street
packages.")
(license license:asl2.0)))
+
+(define-public ocaml-ppx-typerep-conv
+ (package
+ (name "ocaml-ppx-typerep-conv")
+ (version "0.11.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/janestreet/ppx_typerep_conv.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0a13dpfrrg0rsm8qni1bh7pqcda30l70z8r6yzi5a64bmwk7g5ah"))))
+ (build-system dune-build-system)
+ (arguments
+ `(#:test-target "."))
+ (propagated-inputs
+ `(("ocaml-base" ,ocaml-base)
+ ("ocaml-typerep" ,ocaml-typerep)
+ ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+ ("ocaml-ppxlib" ,ocaml-ppxlib)))
+ (properties `((upstream-name . "ppx_typerep_conv")))
+ (home-page "https://github.com/janestreet/ppx_typerep_conv")
+ (synopsis "Generation of runtime types from type declarations")
+ (description "This package can automatically generate runtime types
+from type definitions.")
+ (license license:asl2.0)))