aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-08 18:28:43 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-08 19:21:20 +0200
commitc67f603d5508ff6fa8bf5b0185c53c40bc8646a3 (patch)
tree5512bab750b56ea3d140bbea904863cc049a2115
parent92af3ce417fdcb932c3f291e0c79106466a40c66 (diff)
downloadguix-c67f603d5508ff6fa8bf5b0185c53c40bc8646a3.tar
guix-c67f603d5508ff6fa8bf5b0185c53c40bc8646a3.tar.gz
gnu: xf86-video-sis: Fix FTBFS with xorg-server >= 1.20.
* gnu/packages/patches/xf86-video-sis-xorg-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/xorg.scm (xf86-video-sis)[source](patches): Use it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/xf86-video-sis-xorg-compat.patch18
-rw-r--r--gnu/packages/xorg.scm1
3 files changed, 20 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index d2490dd5b7..89bad3d2ab 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1215,6 +1215,7 @@ dist_patch_DATA = \
%D%/packages/patches/xf86-video-i128-remove-mibstore.patch \
%D%/packages/patches/xf86-video-mach64-glibc-2.20.patch \
%D%/packages/patches/xf86-video-siliconmotion-fix-ftbfs.patch \
+ %D%/packages/patches/xf86-video-sis-xorg-compat.patch \
%D%/packages/patches/xf86-video-tga-remove-mibstore.patch \
%D%/packages/patches/xfce4-panel-plugins.patch \
%D%/packages/patches/xfce4-session-fix-xflock4.patch \
diff --git a/gnu/packages/patches/xf86-video-sis-xorg-compat.patch b/gnu/packages/patches/xf86-video-sis-xorg-compat.patch
new file mode 100644
index 0000000000..ebe9715d13
--- /dev/null
+++ b/gnu/packages/patches/xf86-video-sis-xorg-compat.patch
@@ -0,0 +1,18 @@
+Remove use of interface no longer provided by xorg-server.
+
+Patch taken from upstream:
+https://cgit.freedesktop.org/xorg/driver/xf86-video-sis/commit/?id=4b1356a2b7fd06e9a05d134caa4033681c939737
+
+diff --git a/src/sis_driver.c b/src/sis_driver.c
+index 8f06164..513f68b 100644
+--- a/src/sis_driver.c
++++ b/src/sis_driver.c
+@@ -2738,7 +2738,7 @@ SiSPrintModes(ScrnInfoPtr pScrn)
+ float hsync, refresh = 0.0;
+ char *desc, *desc2, *prefix, *uprefix, *output;
+
+- xf86DrvMsg(pScrn->scrnIndex, pScrn->virtualFrom, "Virtual size is %dx%d "
++ xf86DrvMsg(pScrn->scrnIndex, X_INFO, "Virtual size is %dx%d "
+ "(pitch %d)\n", pScrn->virtualX, pScrn->virtualY,
+ pScrn->displayWidth);
+
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 4ce02b783c..f253d79614 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -3266,6 +3266,7 @@ Xorg X server.")
"mirror://xorg/individual/driver/xf86-video-sis-"
version
".tar.bz2"))
+ (patches (search-patches "xf86-video-sis-xorg-compat.patch"))
(sha256
(base32
"03f1abjjf68y8y1iz768rn95va9d33wmbwfbsqrgl6k0gi0bf9jj"))))