aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrendan Tildesley <brendan.tildesley@openmailbox.org>2017-11-24 02:22:53 +1100
committerLudovic Courtès <ludo@gnu.org>2017-11-23 22:54:03 +0100
commit0dcad042a5180d275a96d2870092f40a4f7542ec (patch)
tree98af70b83d9d819bcadcad200ac9a38650c06988
parentbe10e4ae4ab7fcb8735c34781432a1109dcfbd88 (diff)
downloadguix-0dcad042a5180d275a96d2870092f40a4f7542ec.tar
guix-0dcad042a5180d275a96d2870092f40a4f7542ec.tar.gz
gnu: pcmanfm: Add missing inputs. Remove comment.
* gnu/packages/lxde.scm (pcmanfm)[inputs]: Add GVFS. [propagated-inputs]: Add LXMENU-DATA. Remove comment suggesting to use --sysconfdir. Inspection of the configure script shows that <output>/etc is used for configuration by default anyway, so such a flag is not needed. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/lxde.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index bf70bd6013..44e5da444d 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2017 Brendan Tildesley <brendan.tildesley@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -218,14 +219,15 @@ speed up the access to freedesktop.org defined application menus.")
(base32
"0rxdh0dfzc84l85c54blq42gczygq8adhr3l9hqzy1dp530cm1hc"))))
(build-system gnu-build-system)
- ;; (#:configure-flags '("--sysconfdir=/etc")) suggested in README.
(inputs `(("gtk+" ,gtk+-2)
- ;; TODO: add ("gvfs" ,gvfs).
+ ("gvfs" ,gvfs) ;for trash and mount support
("libfm" ,libfm)
("libx11" ,libx11)))
(native-inputs `(("intltool" ,intltool)
("libtool" ,libtool)
("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("lxmenu-data" ,lxmenu-data))) ;for "Open With..." application list
(synopsis "LXDE file manager")
(description "PCMan is a lightweight GTK+ based file manager, compliant
with freedesktop.org standard.")