aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-01-13 19:58:17 +0000
committerChristopher Baines <mail@cbaines.net>2020-01-13 20:01:01 +0000
commite10d49c9622e213b2028e57f9d318ed37bbb89de (patch)
tree34bc23d8633cda74a2ff0e8e50769e5cddb88dd7
parentf30aad8fd402a11b29876d322f72c85873b2c801 (diff)
downloadguix-e10d49c9622e213b2028e57f9d318ed37bbb89de.tar
guix-e10d49c9622e213b2028e57f9d318ed37bbb89de.tar.gz
gnu: ruby-childprocess: Update to 3.0.0.
* gnu/packages/ruby.scm (ruby-childprocess): Update to 3.0.0. [home-page]: Switch to https, as it's supported by github.com.
-rw-r--r--gnu/packages/ruby.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index f1fa9310eb..d7c9383b45 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7427,14 +7427,14 @@ in standard Ruby syntax.")
(define-public ruby-childprocess
(package
(name "ruby-childprocess")
- (version "0.9.0")
+ (version "3.0.0")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "childprocess" version))
(sha256
(base32
- "0a61922kmvcxyj5l70fycapr87gz1dzzlkfpq85rfqk5vdh3d28p"))))
+ "1ic028k8xgm2dds9mqnvwwx3ibaz32j8455zxr9f4bcnviyahya5"))))
(build-system ruby-build-system)
(arguments
`(#:tests? #f))
@@ -7446,7 +7446,7 @@ in standard Ruby syntax.")
(synopsis "Control external programs running in the background, in Ruby")
(description "@code{childprocess} provides a gem to control external
programs running in the background, in Ruby.")
- (home-page "http://github.com/enkessler/childprocess")
+ (home-page "https://github.com/enkessler/childprocess")
(license license:expat)))
(define-public ruby-public-suffix