aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-01-13 19:58:02 +0000
committerChristopher Baines <mail@cbaines.net>2020-01-13 20:01:01 +0000
commita79ffca6824eb82e8fd76a2749c6b6238cd977b8 (patch)
treebedd00f2985f3d51250444f06f2cde8edeaf7621
parent8879a4b9354c9da7e2497a9a47eb6ed84548ea76 (diff)
downloadguix-a79ffca6824eb82e8fd76a2749c6b6238cd977b8.tar
guix-a79ffca6824eb82e8fd76a2749c6b6238cd977b8.tar.gz
gnu: ruby-aruba: Update to 0.14.14.
Stop patching out the use of simplecov, it's used throughout the tests now, so it's not as simple to avoid using it. * gnu/packages/ruby.scm (ruby-aruba): Update to 0.14.14. [arguments]: Stop patching out the use of simplecov. [native-inputs]: Add ruby-simplecov.
-rw-r--r--gnu/packages/ruby.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index b8a5c8b5d3..de10a25c5b 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5405,14 +5405,14 @@ It is intended be used by all Cucumber implementations to parse
(define-public ruby-aruba
(package
(name "ruby-aruba")
- (version "0.14.8")
+ (version "0.14.14")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "aruba" version))
(sha256
(base32
- "0zdd81l1lp0x78sxa6kkfqclpj5il3xl70nz05wqv2sfzzhqydxh"))))
+ "0l2mfpdxc03gdrbwc2hv4vdhjhqhfcdp6d02j05j64ncpi9srlqn"))))
(build-system ruby-build-system)
(arguments
'(#:test-target "spec"
@@ -5444,11 +5444,7 @@ It is intended be used by all Cucumber implementations to parse
((".*cucumber.*") "\n")
((".*license_finder.*") "\n")
((".*rake.*") "gem 'rake'\n")
- ((".*simplecov.*") "\n")
((".*relish.*") "\n"))
- (substitute* "spec/spec_helper.rb"
- ((".*simplecov.*") "")
- (("^SimpleCov.*") ""))
(substitute* "aruba.gemspec"
(("spec\\.add\\_runtime\\_dependency 'cucumber'.*")
"spec.add_runtime_dependency 'cucumber'"))
@@ -5458,7 +5454,8 @@ It is intended be used by all Cucumber implementations to parse
(native-inputs
`(("bundler" ,bundler)
("ruby-rspec" ,ruby-rspec)
- ("ruby-fuubar" ,ruby-fuubar)))
+ ("ruby-fuubar" ,ruby-fuubar)
+ ("ruby-simplecov" ,ruby-simplecov)))
(propagated-inputs
`(("ruby-childprocess" ,ruby-childprocess)
("ruby-contracts" ,ruby-contracts)