aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-01-13 19:58:22 +0000
committerChristopher Baines <mail@cbaines.net>2020-01-13 20:01:01 +0000
commit7ffb5fb83f5deabc2210c6e9b76deffd69ad1dc4 (patch)
treed5f62f4c65d5abe9704724366f9838c597a925d6
parente10d49c9622e213b2028e57f9d318ed37bbb89de (diff)
downloadguix-7ffb5fb83f5deabc2210c6e9b76deffd69ad1dc4.tar
guix-7ffb5fb83f5deabc2210c6e9b76deffd69ad1dc4.tar.gz
gnu: ruby-yard: Update to 0.9.20.
* gnu/packages/ruby.scm (ruby-yard): Update to 0.9.20. [arguments]: Delete the Gemfile before running the tests. [native-inputs]: Add ruby-redcloth and ruby-asciidoctor.
-rw-r--r--gnu/packages/ruby.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d7c9383b45..140cdb9aab 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5747,7 +5747,7 @@ A modified copy of yajl is used, and included in the package.")
(define-public ruby-yard
(package
(name "ruby-yard")
- (version "0.9.16")
+ (version "0.9.20")
(source
(origin
(method git-fetch)
@@ -5758,20 +5758,24 @@ A modified copy of yajl is used, and included in the package.")
(file-name (git-file-name name version))
(sha256
(base32
- "0a4r1pfs0ms4vlccsf1x2jckx35lqm8b8lh6rdjxqfr5fia5izpf"))))
+ "1v48zz8hzazrg79jksj9siys21d2axvzijvkxw2j42zh86syi1wi"))))
(build-system ruby-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(replace 'check
(lambda _
+ ;; Delete the Gemfile to avoid errors relating to it
+ (delete-file "Gemfile")
;; $HOME needs to be set to somewhere writeable for tests to run
(setenv "HOME" "/tmp")
;; Run tests without using 'rake' to avoid dependencies.
(invoke "rspec"))))))
(native-inputs
`(("ruby-rspec" ,ruby-rspec)
- ("ruby-rack" ,ruby-rack)))
+ ("ruby-rack" ,ruby-rack)
+ ("ruby-redcloth" ,ruby-redcloth)
+ ("ruby-asciidoc" ,ruby-asciidoctor)))
(synopsis "Documentation generation tool for Ruby")
(description
"YARD is a documentation generation tool for the Ruby programming