aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-01-13 19:58:56 +0000
committerChristopher Baines <mail@cbaines.net>2020-01-13 20:01:02 +0000
commit782c2fbab3d5f45ace27e25666c88369e06a1e85 (patch)
tree8ed5d3fb17658a939acaf168f756860c1c5637d2
parentb2fecfce16f0f147252d591c61e2564934d8f449 (diff)
downloadguix-782c2fbab3d5f45ace27e25666c88369e06a1e85.tar
guix-782c2fbab3d5f45ace27e25666c88369e06a1e85.tar.gz
gnu: ruby-tzinfo: Skip safe tests.
The safe tests attempt to run with Ruby 2.6, but these tests fail if the build takes place within /tmp, as the Ruby LOAD_PATH then includes /tmp, which is world writable. * gnu/packages/ruby.scm (ruby-tzinfo)[arguments]: Add skip-safe-tests phase.
-rw-r--r--gnu/packages/ruby.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index b39769acaa..088b975a22 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4072,6 +4072,16 @@ utilities for Ruby.")
(base32
"09dpbrih054mn42flbbcdpzk2727mzfvjrgqb12zdafhx7p9rrzp"))))
(build-system ruby-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-safe-tests
+ (lambda _
+ (substitute* "test/test_utils.rb"
+ (("def safe_test\\(options = \\{\\}\\)")
+ "def safe_test(options = {})
+ skip('The Guix build environment has an unsafe load path')"))
+ #t)))))
(propagated-inputs
`(("ruby-thread-safe" ,ruby-thread-safe)))
(synopsis "Time zone library for Ruby")