aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-04 17:26:02 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-04 20:05:21 +0100
commitee2d63db617277a9f6e6b8c511886967b6947272 (patch)
treeef659dd17e1b430f3cb30d7fcc854ebf979bf921
parentbc148ba47ddc15d1cd7100fb2e67eddbbb7461ec (diff)
downloadguix-ee2d63db617277a9f6e6b8c511886967b6947272.tar
guix-ee2d63db617277a9f6e6b8c511886967b6947272.tar.gz
gnu: eudev: Download using git.
* gnu/packages/linux.scm (eudev)[source]: Change to GIT-FETCH. [arguments]: Add phase "make-source-writable".
-rw-r--r--gnu/packages/linux.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9d61734f34..6e4fac78ba 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2040,18 +2040,24 @@ from the module-init-tools project.")
(name "eudev")
(version "3.2.5")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/gentoo/eudev/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference (url "https://github.com/gentoo/eudev")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0dlkcgy7j4fdcksqrpc373zfybiif1bal3n6lpy1kfc5280j02c7"))
+ "0x23vxybvciskfbdgvp4ygkxdh2pjcglni29i36a09ii23lgs17l"))
(patches (search-patches "eudev-rules-directory.patch"))))
(build-system gnu-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'make-source-writable
+ (lambda _
+ ;; XXX: Git checkouts are read-only, but this package needs to
+ ;; modify some of its files.
+ (for-each make-file-writable (find-files "."))
+ #t))
(add-before 'bootstrap 'patch-file-names
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "man/make.sh"