aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-11-27 16:56:12 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-11-29 14:45:41 +0100
commite2b9ed7fcc019df290f0f5bbe221803efb031123 (patch)
treed45aa6a0f235d3a791a53b6c32526424d17fc77c
parentc324ad52b6066b4626312a4120b645c43989dd0a (diff)
downloadguix-e2b9ed7fcc019df290f0f5bbe221803efb031123.tar
guix-e2b9ed7fcc019df290f0f5bbe221803efb031123.tar.gz
gnu: kmscon: Don't invoke './configure' during bootstrap.
* gnu/packages/terminals.scm (kmscon)[arguments]: Change 'autogen.sh' phase to replace 'bootstrap' and set the $NOCONFIGURE environment variable.
-rw-r--r--gnu/packages/terminals.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 0f11fa650a..2d15d77524 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -240,9 +240,10 @@ compatibility to existing emulators like xterm, gnome-terminal, konsole, etc.")
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'autogen.sh
+ (replace 'bootstrap
(lambda _
- (zero? (system* "sh" "autogen.sh"))))
+ (setenv "NOCONFIGURE" "indeed")
+ (invoke "sh" "autogen.sh")))
;; Use elogind instead of systemd.
(add-before 'configure 'remove-systemd
(lambda _