aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-11-26 19:31:15 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2018-11-26 19:44:29 +0100
commitde42429040d1754301fe76e5de53deda3e973027 (patch)
treeb895571784f56a833131ab6798534d3efe20e414
parent6cbb2c87216e37f4d11a36d3d95d6c5fa5dc9216 (diff)
downloadguix-de42429040d1754301fe76e5de53deda3e973027.tar
guix-de42429040d1754301fe76e5de53deda3e973027.tar.gz
gnu: mono: Fix build with glibc 2.28.
* gnu/packages/mono.scm (mono)[arguments]<#:phases>[fix-includes]: New phase.
-rw-r--r--gnu/packages/mono.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/mono.scm b/gnu/packages/mono.scm
index 16c4f71dde..71d7aeac65 100644
--- a/gnu/packages/mono.scm
+++ b/gnu/packages/mono.scm
@@ -56,6 +56,13 @@
(lambda _ ;;* (#:key inputs #:allow-other-keys)
;; all tests under mcs/class fail trying to access $HOME
(setenv "HOME" "/tmp")))
+ (add-after 'unpack 'fix-includes
+ (lambda _
+ ;; makedev is in <sys/sysmacros.h> now. Include it.
+ (substitute* "mono/io-layer/processes.c"
+ (("#ifdef HAVE_SYS_MKDEV_H") "#if 1")
+ (("sys/mkdev.h") "sys/sysmacros.h"))
+ #t))
(add-after 'unpack 'patch-tests
(lambda _ ;;* (#:key inputs #:allow-other-keys)
(substitute* "mono/tests/Makefile.in"