aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-03 17:20:18 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-03 17:44:14 +0100
commitcee3d7136b18d322ba1b1aa6b1d4ec4217092fa1 (patch)
treeedc1b3e96105330a83b024b08981299a1936ed59
parent650bc9421620862c95f18f0712277f8607713781 (diff)
downloadguix-cee3d7136b18d322ba1b1aa6b1d4ec4217092fa1.tar
guix-cee3d7136b18d322ba1b1aa6b1d4ec4217092fa1.tar.gz
gnu: python-statsmodels: Update to 0.9.0.
* gnu/packages/statistics.scm (python-statsmodels): Update to 0.9.0. [arguments]: Remove obsolete workaround.
-rw-r--r--gnu/packages/statistics.scm17
1 files changed, 3 insertions, 14 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 66f57ac879..cc879be99c 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1876,14 +1876,14 @@ building design matrices.")
(define-public python-statsmodels
(package
(name "python-statsmodels")
- (version "0.8.0")
+ (version "0.9.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "statsmodels" version))
(sha256
(base32
- "0j30v3932shnj9368c9jr3svkyrvfj90h2l7nxnqkbpv0svilhr6"))))
+ "0fxs8a7sp4d7jvqlm36yi45i2d28kjfvraf9q8i9jr1chhxgjqb4"))))
(build-system python-build-system)
(arguments
`(;; The test suite is very large and rather brittle. Tests often fail
@@ -1902,18 +1902,7 @@ building design matrices.")
(("import matplotlib\\.pyplot as plt" line)
(string-append "import matplotlib;matplotlib.use('Agg');"
line)))
- #t))
- ;; FIXME: This is a bug in version 0.8 since the upgrade to scipy 1.0.
- ;; See https://github.com/statsmodels/statsmodels/issues/3931
- ;; This has been fixed in version 0.9.
- (add-after 'unpack 'patch-for-scipy
- (lambda _
- (substitute* "statsmodels/discrete/discrete_model.py"
- (("return stats.chisqprob" match)
- (string-append
- "stats.chisqprob = lambda chisq, df: stats.chi2.sf(chisq, df);"
- match)))
- #t)))))
+ #t)))))
(propagated-inputs
`(("python-numpy" ,python-numpy)
("python-scipy" ,python-scipy)