aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-12-04 16:39:28 -0500
committerLeo Famulari <leo@famulari.name>2018-12-05 14:16:17 -0500
commita7ff66998f6e0eeb5da485bab7f6e0b55a46651e (patch)
tree0d11cbaf392dc0ce39b5790ebcd0b7ce3521f539
parente8de4b1f5fe4f7fdc0c16664e1e6c159755b99dc (diff)
downloadguix-a7ff66998f6e0eeb5da485bab7f6e0b55a46651e.tar
guix-a7ff66998f6e0eeb5da485bab7f6e0b55a46651e.tar.gz
gnu: Boost: Build with C++14.
Some parts of Boost which are used by other Guix packages require C++14 support. Fixes <https://bugs.gnu.org/33605>. * gnu/packages/boost.scm (boost)[arguments]: Pass 'cxxflags=-std=c++14' to #:make-flags.
-rw-r--r--gnu/packages/boost.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index b772781f56..f5c2c58300 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -67,6 +67,7 @@
`(#:tests? #f
#:make-flags
(list "threading=multi" "link=shared"
+ "cxxflags=-std=c++14"
;; Set the RUNPATH to $libdir so that the libs find each other.
(string-append "linkflags=-Wl,-rpath="