aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-02 18:33:57 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-03 17:44:13 +0100
commit8aaec042d4a7cff68c219443517b55b1d9f0ee9c (patch)
tree3624dd3e0caf426e3460a224d20b7481fbe15303
parentaefcdea1992bbcc6c0ec1107118d08d72af38021 (diff)
downloadguix-8aaec042d4a7cff68c219443517b55b1d9f0ee9c.tar
guix-8aaec042d4a7cff68c219443517b55b1d9f0ee9c.tar.gz
gnu: kicad: Fix build with Boost >= 1.68.
* gnu/packages/engineering.scm (kicad)[arguments]: Add phase 'adjust-boost-include'.
-rw-r--r--gnu/packages/engineering.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 0080356494..8ef9a5c277 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -717,6 +717,13 @@ language.")
"-DBUILD_GITHUB_PLUGIN=OFF")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'adjust-boost-include
+ (lambda _
+ ;; The location of this header changed in Boost 1.66.
+ (substitute* "3d-viewer/3d_cache/3d_cache.cpp"
+ (("boost/uuid/sha1\\.hpp")
+ "boost/uuid/detail/sha1.hpp"))
+ #t))
(add-after 'install 'wrap-program
;; Ensure correct Python at runtime.
(lambda* (#:key inputs outputs #:allow-other-keys)