aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-11-27 13:51:52 +0100
committerLudovic Courtès <ludo@gnu.org>2018-11-27 13:51:52 +0100
commit8aad2e32e5d954bc72aa8ef4da9c22f1619b64cd (patch)
tree4779ac4dcfd2896de181279eb84b5b5eeb65782f
parentbc0d24292d776826b8ce9c9aa9d620e33160d1ed (diff)
downloadguix-8aad2e32e5d954bc72aa8ef4da9c22f1619b64cd.tar
guix-8aad2e32e5d954bc72aa8ef4da9c22f1619b64cd.tar.gz
gnu: orbit2: Do not build static libraries.
* gnu/packages/gnome.scm (orbit2)[arguments]: Add "--disable-static" to #:configure-flags.
-rw-r--r--gnu/packages/gnome.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 026b5fd59c..bf63c37c2b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1321,9 +1321,13 @@ functionality was designed to be as reusable and portable as possible.")
(build-system gnu-build-system)
(arguments
`(#:configure-flags
- ;; The programmer kindly gives us a hook to turn off deprecation
- ;; warnings ...
- '("DISABLE_DEPRECATED_CFLAGS=-DGLIB_DISABLE_DEPRECATION_WARNINGS")
+ '(;; We don't need static libraries, plus they don't build reproducibly
+ ;; (non-deterministic ordering of .o files in the archive.)
+ "--disable-static"
+
+ ;; The programmer kindly gives us a hook to turn off deprecation
+ ;; warnings ...
+ "DISABLE_DEPRECATED_CFLAGS=-DGLIB_DISABLE_DEPRECATION_WARNINGS")
;; ... which they then completly ignore !!
#:phases
(modify-phases %standard-phases